A computer components & hardware forum. HardwareBanter

If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

Go Back   Home » HardwareBanter forum » General Hardware & Peripherals » General
Site Map Home Register Authors List Search Today's Posts Mark Forums Read Web Partners

Creative Labs X-Fi Elite Pro Soundblaster 7.1 stops working after recent windows 7 update.



 
 
Thread Tools Display Modes
  #1  
Old June 29th 15, 10:02 PM posted to alt.audio,alt.comp.hardware,alt.comp.hardware.pc-homebuilt,sci.electronics.design
Skybuck Flying[_4_]
external usenet poster
 
Posts: 476
Default Creative Labs X-Fi Elite Pro Soundblaster 7.1 stops working after recent windows 7 update.

Hello,

Today 29 june 2015 after installing Microsoft Windows 7 updates the Creative
Labs X-Fi Elite Pro Soundblaster 7.1 stopped working. (No more sound, no
more audio devices available for console launcher, software for
soundblaster).

The update process went as follows: I accidently clicked install, I did not
want to install IE9 so I cancelled the updates. I deselected IE9 because it
malfunctions on my system.

Then I proceeded as normal with installing updates, it seemed to download
them normally and installed them normally.

Then I started playing Company of Heroes on Tunngle in a 4 v 4 match I found
out the sound was no longer working ?!

Alt-tabbing and trying to select an audio device was also not helping. SB-XI
AC00 is visible from menu... so it seems the soundblaster is alive and well
but the software is not.

So it seems like a software problem.

The updates installed we

1.
Security Update for Windows 7 for x64-based Systems (KB3033890)
Installation date: ‎29/‎6/‎2015 22:08
Installation status: Successful
Update type: Important
A security issue has been identified in a Microsoft software product that
could affect your system. You can help protect your system by installing
this update from Microsoft. For a complete listing of the issues that are
included in this update, see the associated Microsoft Knowledge Base
article. After you install this update, you may have to restart your system.
More information:
http://support.microsoft.com/kb/3033890

2.
Update for Windows 7 for x64-based Systems (KB2952664)
Installation date: ‎29/‎6/‎2015 22:07
Installation status: Successful
Update type: Recommended
Install this update to resolve issues in Windows. For a complete listing of
the issues that are included in this update, see the associated Microsoft
Knowledge Base article for more information. After you install this item,
you may have to restart your computer.
More information:
http://support.microsoft.com/kb/2952664

3.
Update for Windows 7 for x64-based Systems (KB3068708)
Installation date: ‎29/‎6/‎2015 22:07
Installation status: Successful
Update type: Recommended
Install this update to resolve issues in Windows. For a complete listing of
the issues that are included in this update, see the associated Microsoft
Knowledge Base article for more information. After you install this item,
you may have to restart your computer.
More information:
http://support.microsoft.com/kb/3068708

4.
Security Update for Windows 7 for x64-based Systems (KB3059317)
Installation date: ‎29/‎6/‎2015 22:06
Installation status: Successful
Update type: Important
A security issue has been identified in a Microsoft software product that
could affect your system. You can help protect your system by installing
this update from Microsoft. For a complete listing of the issues that are
included in this update, see the associated Microsoft Knowledge Base
article. After you install this update, you may have to restart your system.
More information:
http://support.microsoft.com/kb/3059317

5.
Cumulative Security Update for Internet Explorer 8 for Windows 7 for
x64-based Systems (KB3058515)
Installation date: ‎29/‎6/‎2015 22:05
Installation status: Successful
Update type: Important
A security issue has been identified in a Microsoft software product that
could affect your system. You can help protect your system by installing
this update from Microsoft. For a complete listing of the issues that are
included in this update, see the associated Microsoft Knowledge Base
article. After you install this update, you may have to restart your system.
More information:
http://support.microsoft.com/kb/3058515

6.
Security Update for Windows 7 for x64-based Systems (KB3057839)
Installation date: ‎29/‎6/‎2015 22:05
Installation status: Successful
Update type: Important
A security issue has been identified in a Microsoft software product that
could affect your system. You can help protect your system by installing
this update from Microsoft. For a complete listing of the issues that are
included in this update, see the associated Microsoft Knowledge Base
article. After you install this update, you may have to restart your system.
More information:
http://support.microsoft.com/kb/3057839

7.
Security Update for Windows 7 for x64-based Systems (KB3063858)
Installation date: ‎29/‎6/‎2015 22:05
Installation status: Successful
Update type: Important
A security issue has been identified in a Microsoft software product that
could affect your system. You can help protect your system by installing
this update from Microsoft. For a complete listing of the issues that are
included in this update, see the associated Microsoft Knowledge Base
article. After you install this update, you may have to restart your system.
More information:
http://support.microsoft.com/kb/3063858

8.
Update for Windows 7 for x64-based Systems (KB3054476)
Installation date: ‎29/‎6/‎2015 22:05
Installation status: Successful
Update type: Recommended
Install this update to resolve issues in Windows. For a complete listing of
the issues that are included in this update, see the associated Microsoft
Knowledge Base article for more information. After you install this item,
you may have to restart your computer.
More information:
http://support.microsoft.com/kb/3054476

The only thing odd about it is the cancelled updates are exactly the same
(except for additional IE9 cancel) but in a different order in the list, not
sure if that has anything to do with it.

For now I am at a loss how to get the soundblaster working again. I have
seen a problem like this before... it's kinda strange... perhaps I may have
to re-install x-fi elite pro soundblaster drivers... or perhaps windows 7
updates is causing an incompatibility or problem somehow.

Things I may try:

1. Re-boot again.

2. Re-install drivers.

3. Google for other people with same problem and possibly
fixes/solutions/software updates.

4. De-install windows updates yet again ?!

I share this problem with you in case other owners of X-Fi Elite Pro
Soundblaster 7.1 are suddenly also running into this issue.

Bye,
Skybuck.

  #2  
Old June 29th 15, 10:14 PM posted to alt.audio,alt.comp.hardware,alt.comp.hardware.pc-homebuilt,sci.electronics.design
TTman
external usenet poster
 
Posts: 3
Default Creative Labs X-Fi Elite Pro Soundblaster 7.1 stops working afterrecent windows 7 update.

On 29/06/2015 22:02, Skybuck Flying wrote:
Hello,

Today 29 june 2015 after installing Microsoft Windows 7 updates the
Creative Labs X-Fi Elite Pro Soundblaster 7.1 stopped working. (No more
sound, no more audio devices available for console launcher, software
for soundblaster).

The update process went as follows: I accidently clicked install, I did
not want to install IE9 so I cancelled the updates. I deselected IE9
because it malfunctions on my system.

Then I proceeded as normal with installing updates, it seemed to
download them normally and installed them normally.

SNIP
You should check that that OLD soundblaster 7.1 is actually supported by
WIN7. A lot of old stuff isn't worth the effort of writing new drivers,
i.e. my HP1010 laser printer




---
This email is free from viruses and malware because avast! Antivirus protection is active.
https://www.avast.com/antivirus

  #3  
Old June 29th 15, 10:16 PM posted to alt.audio,alt.comp.hardware,alt.comp.hardware.pc-homebuilt,sci.electronics.design
Skybuck Flying[_4_]
external usenet poster
 
Posts: 476
Default Creative Labs X-Fi Elite Pro Soundblaster 7.1 stops working after recent windows 7 update.

Yes it's supported, I believe windows update even has a special update for
it... but it should not be necessary.

It was also working fine before update... see more in my other postings.

Bye,
Skybuck.

  #4  
Old June 29th 15, 10:33 PM posted to alt.audio,alt.comp.hardware,alt.comp.hardware.pc-homebuilt,sci.electronics.design
Skybuck Flying[_4_]
external usenet poster
 
Posts: 476
Default Creative Labs X-Fi Elite Pro Soundblaster 7.1 stops working after recent windows 7 update.

Attempt 1 at trying to fix it:

Motherboard integrated realtek audio chip '97 was available in audio device
selection pop-up menu. (Bios setting was "auto")

Rebooted, into bios, disabled this chip, reboot into windows 7.

Did notice faster boot time, no more 10 minute hang, could be a fluke of
luck or a solved hardware conflict between x-fi soundblaster and realtek
audio chip.

Effects of this attempt:

Faster boot time ?

Console launcher does show up, but it looks very weird, all usually controls
are missing from it, see link for screenshot:

To me this is starting to seem like a true software fok up of some kind:

http://www.skybuck.org/Windows7/XFiS...ows7Update.png

The following updates look suspicious to me:

At the top of the list is the evil looking one, which is supposedly to
prepare my system for an update to windows 10:

https://support.microsoft.com/en-us/kb/2952664

"This update helps Microsoft make improvements to the current operating
system in order to ease the upgrade experience to the latest version of
Windows."

^ This seems highly evil to me... I will try de-install this next, if it
doesn't help I will de-install all the mention updates.


Another update which looks suspicious is the one which affects stream.sys
drived based applications ?:

8:
https://support.microsoft.com/en-us/kb/3054476

Bye,
Skybuck.

  #5  
Old June 29th 15, 10:36 PM posted to alt.audio,alt.comp.hardware,alt.comp.hardware.pc-homebuilt,sci.electronics.design
Skybuck Flying[_4_]
external usenet poster
 
Posts: 476
Default Creative Labs X-Fi Elite Pro Soundblaster 7.1 stops working after recent windows 7 update.

However before messing around with updates...

I will first check for newer drivers from creative labs and failing that I
will try and re-install the "driver update" from Creative Labs.

Just to see if that will restore operating of the soundblaster.

Perhaps some kind of driver file was removed or damaged by the windows
update.

It's worth a try I hope I don't nuke my driver stack and stuff like that...
but I think it will be safe to do so.

Bye for now,
Skybuck.

  #6  
Old June 29th 15, 10:41 PM posted to alt.audio,alt.comp.hardware,alt.comp.hardware.pc-homebuilt,sci.electronics.design
Skybuck Flying[_4_]
external usenet poster
 
Posts: 476
Default Creative Labs X-Fi Elite Pro Soundblaster 7.1 stops working after recent windows 7 update.

Hmm can't check for newer drivers, I am almost not sure if the latest driver
I have available from 2014 is the good one, or perhaps the one from 2011.

I would guess the one from 2014, but I am not sure, perhaps I had it
documented somewhere.

Well I am not going through with my earlier plan cause everything was
working fine before the windows update.

So instead I am going to go with my gutt feeling that this might be an
attempt of Microsoft to sabotage my system to try and force people into
windows 10.

Or it's just another one of their general windows update **** ups.

So I am going to slowly de-install these updates to see if that fixes it...
then later I could always try re-installing them if it didn't help and then
finally re-install the driver.

Bye,
Skybuck.

  #7  
Old June 29th 15, 10:43 PM posted to alt.audio,alt.comp.hardware,alt.comp.hardware.pc-homebuilt,sci.electronics.design
Skybuck Flying[_4_]
external usenet poster
 
Posts: 476
Default Creative Labs X-Fi Elite Pro Soundblaster 7.1 stops working after recent windows 7 update.

"
SNIP
You should check that that OLD soundblaster 7.1 is actually supported by
WIN7. A lot of old stuff isn't worth the effort of writing new drivers,
i.e. my HP1010 laser printer
"

I find your posting very weird. If it was working before then that
automatically means it's supported, doesn't it ?

Yes it is supported by Creative Labs at the very least, and even Microsoft
itself.

By drivers.

Can't reach creative labs website right now... it seems very slow... but it
doesn't matter. I am going to try de-installing evil looking updates first,
then all if necessary... to see if that fixes it...

If it does... then that basically proves it's a problem with the windows 7
updates !

Bye,
Skybuck.

  #8  
Old June 29th 15, 10:46 PM posted to alt.audio,alt.comp.hardware,alt.comp.hardware.pc-homebuilt,sci.electronics.design
Skybuck Flying[_4_]
external usenet poster
 
Posts: 476
Default Creative Labs X-Fi Elite Pro Soundblaster 7.1 stops working after recent windows 7 update.

"
SNIP
You should check that that OLD soundblaster 7.1 is actually supported by
WIN7. A lot of old stuff isn't worth the effort of writing new drivers,
i.e. my HP1010 laser printer
"

Also I wouldn't call it "OLD" if I were you !

It's still one of the best soundblasters out there... and one of the only
few that does 7.1 great ! Plus great software !

Even Creative Labs does not seem to have a newer product which can match
it's class and feature set.

As far as I am concerned X-Fi Elite Pro Soundblaster 7.1 is still
state-of-the-art / feature-complete !

I am looking for a new soundblaster for my new system.

If you believe there is anything better out there that can out-match and
out-class this soundblaster, in 7.1 capabilities and software feature-set
let me know !

It should be an internal card though... not the weird external things
creative labs is selling nowadays... and definetly 7.1 !

Bye,
Skybuck.

  #9  
Old June 29th 15, 10:59 PM posted to alt.audio,alt.comp.hardware,alt.comp.hardware.pc-homebuilt,sci.electronics.design
Skybuck Flying[_4_]
external usenet poster
 
Posts: 476
Default Creative Labs X-Fi Elite Pro Soundblaster 7.1 stops working after recent windows 7 update.

Deinstalling update 2, (The suspected evil one) did not result in the sound
working again, the console launcher remains looking weird.

I will now first try de-installing all the updates to see if that would fix
the sound situation.

Again no more boot-freeze of 10 minutes... kinda interesting.

Bye,
Skybuck.

  #10  
Old June 29th 15, 11:03 PM posted to alt.audio,alt.comp.hardware,alt.comp.hardware.pc-homebuilt,sci.electronics.design
Skybuck Flying[_4_]
external usenet poster
 
Posts: 476
Default Creative Labs X-Fi Elite Pro Soundblaster 7.1 stops working after recent windows 7 update.

Actually I like to mention something else which happened to today.

The trouble and messing around with updates started for two reasons:

1. First of all tunngle could not finalize anymore... and even more weird:

Disabling the network adapter did not seem to work... the "re-enable" would
not show.

The I disabled the internet connection, but it also did not show
"re-enable".

So I decided to reboot.

I can't remember if this was before or after the updates.

But it might be related to these updates as well.

Not sure... but I thought I'd mention it in case somebody else is noticing
problems with disabling network adapters.

It was kinda odd.

Perhaps this issue would have shown up in future more... but for now I am
de-installing these updates.

To see what the effect of that is on my system and sound and so forth.

2. Security concerns... been a while since I installed updates... just these
8 were waiting though... and some other ones unwanted.

Bye,
Skybuck.

 




Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Recent Windows update stops Brother MFC620 printing multiple copies Gel Printers 1 November 1st 09 05:56 AM
[FOR SALE] Creative X-FI Extreme Gamer + Creative X-FI Elite Pro! Zanx General 1 June 11th 08 09:35 PM
A recent Windows Update potentially causes problems with Word, Excel,IE,... Bob Pownall Dell Computers 3 April 19th 06 12:40 AM
P5nd2-sli : cdrom stops working after windows installs [email protected] Asus Motherboards 2 June 4th 05 10:16 PM
ASUS P4C800-E Deluxe + Nvidia GeForceFX 5900 Ultra + Creative Labs SoundBlaster Audigy 2 Platinum eX + Adaptec AHA2940UW UltraWide SCSI Controller Vincent Poy Asus Motherboards 1 July 15th 03 07:45 AM


All times are GMT +1. The time now is 06:02 AM.


Powered by vBulletin® Version 3.6.4
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
Copyright 2004-2021 HardwareBanter.
The comments are property of their posters.