A computer components & hardware forum. HardwareBanter

If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

Go Back   Home » HardwareBanter forum » General Hardware & Peripherals » Cdr
Site Map Home Register Authors List Search Today's Posts Mark Forums Read Web Partners

DMA on/off



 
 
Thread Tools Display Modes
  #1  
Old June 13th 04, 05:14 PM
DaveB
external usenet poster
 
Posts: n/a
Default DMA on/off

Mydvd writer is reading dvds at single speed ..and it is really
frustrating....

Can some kind soul put me out f my misery and tell me how to turn DMA back
on (enable)

Thanx as always

Dave




  #2  
Old June 13th 04, 06:29 PM
SleeperMan
external usenet poster
 
Posts: n/a
Default

DaveB typed:

Mydvd writer is reading dvds at single speed ..and it is really
frustrating....

Can some kind soul put me out f my misery and tell me how to turn DMA
back on (enable)

Thanx as always

Dave


If you run XP, i think this is what you wanted:

Getting back to DMA mode in Windows XP


CD-ROM and DVD-ROM drives can revert to using PIO mode, despite being set to
use "DMA if Available." Here's how to make Windows XP redetect the DMA
capabilities of the drives.
This behaviour occurs with the following conditions:
Windows XP is the operating system
A CD-ROM or DVD-ROM drive, which is known to support DMA mode now works only
in PIO mode.
The drive controller is set to use "DMA if available" but reports to be only
in PIO mode.
Following is the mechanism that has worked for me, please try it at your own
risk, it involves hacking the registry:

Open RegEdit

Find the following KEY:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Contro l\
Class\{4D36E96A-E325-11CE-BFC1-08002BE10318}\000x

The last four digits will be 0000, 0001, 0002, 0003, and so on.
Under each key, delete all occurences of the following values:
MasterIdDataChecksum
SlaveIdDataChecksum
Reboot the computer. Windows will now redetect DMA settings.
Trala!


  #3  
Old June 13th 04, 08:05 PM
DaveB
external usenet poster
 
Posts: n/a
Default

Sleeperman, thanx for reply

Xp says system is running with DMA enabled, but when i check using Nero it
says DMA is turned off.

I've been to Device Manager but it keeps reporting that all is running with
DMA enabled , but the read/write speed is super slow,
only doing at best 1.1x and taking an hour or more to read.

Your solution looks like it might do the trick but it'll be Mon nite before
i try it - I've never fiddled with the registry before so i hope it all
works out OK.




MAny thanks

Dave


"SleeperMan" wrote in message
...
DaveB typed:

Mydvd writer is reading dvds at single speed ..and it is really
frustrating....

Can some kind soul put me out f my misery and tell me how to turn DMA
back on (enable)

Thanx as always

Dave


If you run XP, i think this is what you wanted:

Getting back to DMA mode in Windows XP


CD-ROM and DVD-ROM drives can revert to using PIO mode, despite being set

to
use "DMA if Available." Here's how to make Windows XP redetect the DMA
capabilities of the drives.
This behaviour occurs with the following conditions:
Windows XP is the operating system
A CD-ROM or DVD-ROM drive, which is known to support DMA mode now works

only
in PIO mode.
The drive controller is set to use "DMA if available" but reports to be

only
in PIO mode.
Following is the mechanism that has worked for me, please try it at your

own
risk, it involves hacking the registry:

Open RegEdit

Find the following KEY:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Contro l\
Class\{4D36E96A-E325-11CE-BFC1-08002BE10318}\000x

The last four digits will be 0000, 0001, 0002, 0003, and so on.
Under each key, delete all occurences of the following values:
MasterIdDataChecksum
SlaveIdDataChecksum
Reboot the computer. Windows will now redetect DMA settings.
Trala!




  #4  
Old June 13th 04, 09:54 PM
Dan G
external usenet poster
 
Posts: n/a
Default

There's no need to mess with the registry. Go to device manager and
uninstall the IDE controller that the drive is on. Then reboot and it should
be good.


"DaveB" wrote in message
...
Sleeperman, thanx for reply

Xp says system is running with DMA enabled, but when i check using Nero it
says DMA is turned off.

I've been to Device Manager but it keeps reporting that all is running

with
DMA enabled , but the read/write speed is super slow,
only doing at best 1.1x and taking an hour or more to read.

Your solution looks like it might do the trick but it'll be Mon nite

before
i try it - I've never fiddled with the registry before so i hope it all
works out OK.




MAny thanks

Dave


"SleeperMan" wrote in message
...
DaveB typed:

Mydvd writer is reading dvds at single speed ..and it is really
frustrating....

Can some kind soul put me out f my misery and tell me how to turn DMA
back on (enable)

Thanx as always

Dave


If you run XP, i think this is what you wanted:

Getting back to DMA mode in Windows XP


CD-ROM and DVD-ROM drives can revert to using PIO mode, despite being

set
to
use "DMA if Available." Here's how to make Windows XP redetect the DMA
capabilities of the drives.
This behaviour occurs with the following conditions:
Windows XP is the operating system
A CD-ROM or DVD-ROM drive, which is known to support DMA mode now works

only
in PIO mode.
The drive controller is set to use "DMA if available" but reports to be

only
in PIO mode.
Following is the mechanism that has worked for me, please try it at your

own
risk, it involves hacking the registry:

Open RegEdit

Find the following KEY:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Contro l\
Class\{4D36E96A-E325-11CE-BFC1-08002BE10318}\000x

The last four digits will be 0000, 0001, 0002, 0003, and so on.
Under each key, delete all occurences of the following values:
MasterIdDataChecksum
SlaveIdDataChecksum
Reboot the computer. Windows will now redetect DMA settings.
Trala!






  #5  
Old June 14th 04, 03:29 PM
SleeperMan
external usenet poster
 
Posts: n/a
Default

True. I never thought of that...
But, to DaveB: Does device manager says DMA if available and below line
Ultra DMA x (1 or 2 i believe), or second line says PIO? Second line
actually states real state of IDE controller.

Dan G typed:

There's no need to mess with the registry. Go to device manager and
uninstall the IDE controller that the drive is on. Then reboot and it
should be good.


"DaveB" wrote in message
...
Sleeperman, thanx for reply

Xp says system is running with DMA enabled, but when i check using
Nero it says DMA is turned off.

I've been to Device Manager but it keeps reporting that all is
running with DMA enabled , but the read/write speed is super slow,
only doing at best 1.1x and taking an hour or more to read.

Your solution looks like it might do the trick but it'll be Mon nite
before i try it - I've never fiddled with the registry before so i
hope it all works out OK.




MAny thanks

Dave


"SleeperMan" wrote in message
...
DaveB typed:

Mydvd writer is reading dvds at single speed ..and it is really
frustrating....

Can some kind soul put me out f my misery and tell me how to turn
DMA back on (enable)

Thanx as always

Dave

If you run XP, i think this is what you wanted:

Getting back to DMA mode in Windows XP


CD-ROM and DVD-ROM drives can revert to using PIO mode, despite
being set to use "DMA if Available." Here's how to make Windows XP
redetect the DMA capabilities of the drives.
This behaviour occurs with the following conditions:
Windows XP is the operating system
A CD-ROM or DVD-ROM drive, which is known to support DMA mode now
works only in PIO mode.
The drive controller is set to use "DMA if available" but reports
to be only in PIO mode.
Following is the mechanism that has worked for me, please try it at
your own risk, it involves hacking the registry:

Open RegEdit

Find the following KEY:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Contro l\
Class\{4D36E96A-E325-11CE-BFC1-08002BE10318}\000x

The last four digits will be 0000, 0001, 0002, 0003, and so on.
Under each key, delete all occurences of the following values:
MasterIdDataChecksum
SlaveIdDataChecksum
Reboot the computer. Windows will now redetect DMA settings.
Trala!




  #6  
Old June 14th 04, 08:44 PM
DaveB
external usenet poster
 
Posts: n/a
Default

Hi and a BIG thanx for your help....

I've had a look at Device Manager and IDE ATA/ATAPI CONTROLLERS - then i
select Primary IDE channel and this is what i have....

Device 0

Device Type - Auto Detection
Transfer Mode - DMA If Available
Current Transfer Mode - Ultra DMA Mode 5

Device 1

Device Type - Auto Detection
Transfer Mode - DMA If Available
Current Transfer Mode - PIO Mode





- now looking at this....me thinks I need to change the bottom setting to
Current Transfer Mode to Ultra DMA mode 5 too



- if i delete the primary IDE channel and re-boot would it pick it up?


Sorry if I appear clueless but ....I am (lol)







"SleeperMan" wrote in message
...
True. I never thought of that...
But, to DaveB: Does device manager says DMA if available and below line
Ultra DMA x (1 or 2 i believe), or second line says PIO? Second line
actually states real state of IDE controller.

Dan G typed:

There's no need to mess with the registry. Go to device manager and
uninstall the IDE controller that the drive is on. Then reboot and it
should be good.


"DaveB" wrote in message
...
Sleeperman, thanx for reply

Xp says system is running with DMA enabled, but when i check using
Nero it says DMA is turned off.

I've been to Device Manager but it keeps reporting that all is
running with DMA enabled , but the read/write speed is super slow,
only doing at best 1.1x and taking an hour or more to read.

Your solution looks like it might do the trick but it'll be Mon nite
before i try it - I've never fiddled with the registry before so i
hope it all works out OK.




MAny thanks

Dave


"SleeperMan" wrote in message
...
DaveB typed:

Mydvd writer is reading dvds at single speed ..and it is really
frustrating....

Can some kind soul put me out f my misery and tell me how to turn
DMA back on (enable)

Thanx as always

Dave

If you run XP, i think this is what you wanted:

Getting back to DMA mode in Windows XP


CD-ROM and DVD-ROM drives can revert to using PIO mode, despite
being set to use "DMA if Available." Here's how to make Windows XP
redetect the DMA capabilities of the drives.
This behaviour occurs with the following conditions:
Windows XP is the operating system
A CD-ROM or DVD-ROM drive, which is known to support DMA mode now
works only in PIO mode.
The drive controller is set to use "DMA if available" but reports
to be only in PIO mode.
Following is the mechanism that has worked for me, please try it at
your own risk, it involves hacking the registry:

Open RegEdit

Find the following KEY:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Contro l\
Class\{4D36E96A-E325-11CE-BFC1-08002BE10318}\000x

The last four digits will be 0000, 0001, 0002, 0003, and so on.
Under each key, delete all occurences of the following values:
MasterIdDataChecksum
SlaveIdDataChecksum
Reboot the computer. Windows will now redetect DMA settings.
Trala!






  #7  
Old June 14th 04, 09:20 PM
DaveB
external usenet poster
 
Posts: n/a
Default

BIG BIG BIG THANKS TO YOU BOTH..........

I bit the bullet, delete the primary IDE and then rebooted, XP picked it up,
re-booted and now my lovely DMA is enabled and is reading dvds like a dream.

Theres a beer in the fridge for you both...

----- THANKS AGAIN..........DAVE ))))))))))))))))))))))))))))))))))))



"DaveB" wrote in message
...
Hi and a BIG thanx for your help....

I've had a look at Device Manager and IDE ATA/ATAPI CONTROLLERS - then i
select Primary IDE channel and this is what i have....

Device 0

Device Type - Auto Detection
Transfer Mode - DMA If Available
Current Transfer Mode - Ultra DMA Mode 5

Device 1

Device Type - Auto Detection
Transfer Mode - DMA If Available
Current Transfer Mode - PIO Mode





- now looking at this....me thinks I need to change the bottom setting to
Current Transfer Mode to Ultra DMA mode 5 too



- if i delete the primary IDE channel and re-boot would it pick it up?


Sorry if I appear clueless but ....I am (lol)







"SleeperMan" wrote in message
...
True. I never thought of that...
But, to DaveB: Does device manager says DMA if available and below line
Ultra DMA x (1 or 2 i believe), or second line says PIO? Second line
actually states real state of IDE controller.

Dan G typed:

There's no need to mess with the registry. Go to device manager and
uninstall the IDE controller that the drive is on. Then reboot and it
should be good.


"DaveB" wrote in message
...
Sleeperman, thanx for reply

Xp says system is running with DMA enabled, but when i check using
Nero it says DMA is turned off.

I've been to Device Manager but it keeps reporting that all is
running with DMA enabled , but the read/write speed is super slow,
only doing at best 1.1x and taking an hour or more to read.

Your solution looks like it might do the trick but it'll be Mon nite
before i try it - I've never fiddled with the registry before so i
hope it all works out OK.




MAny thanks

Dave


"SleeperMan" wrote in message
...
DaveB typed:

Mydvd writer is reading dvds at single speed ..and it is really
frustrating....

Can some kind soul put me out f my misery and tell me how to turn
DMA back on (enable)

Thanx as always

Dave

If you run XP, i think this is what you wanted:

Getting back to DMA mode in Windows XP


CD-ROM and DVD-ROM drives can revert to using PIO mode, despite
being set to use "DMA if Available." Here's how to make Windows XP
redetect the DMA capabilities of the drives.
This behaviour occurs with the following conditions:
Windows XP is the operating system
A CD-ROM or DVD-ROM drive, which is known to support DMA mode now
works only in PIO mode.
The drive controller is set to use "DMA if available" but reports
to be only in PIO mode.
Following is the mechanism that has worked for me, please try it at
your own risk, it involves hacking the registry:

Open RegEdit

Find the following KEY:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Contro l\
Class\{4D36E96A-E325-11CE-BFC1-08002BE10318}\000x

The last four digits will be 0000, 0001, 0002, 0003, and so on.
Under each key, delete all occurences of the following values:
MasterIdDataChecksum
SlaveIdDataChecksum
Reboot the computer. Windows will now redetect DMA settings.
Trala!








  #8  
Old June 15th 04, 01:48 AM
Dan G
external usenet poster
 
Posts: n/a
Default

This a common issue with XP, it'll happen every time you try to read a disc
with a lot of errors. Like a scratched disc or certain protected games, etc,
etc. If you look in Event Viewer, you may find the errors listed there
right before it switches to PIO. Another fine gift from Bill Gates.



"DaveB" wrote in message
...
BIG BIG BIG THANKS TO YOU BOTH..........

I bit the bullet, delete the primary IDE and then rebooted, XP picked it

up,
re-booted and now my lovely DMA is enabled and is reading dvds like a

dream.

Theres a beer in the fridge for you both...

----- THANKS AGAIN..........DAVE ))))))))))))))))))))))))))))))))))))



"DaveB" wrote in message
...
Hi and a BIG thanx for your help....

I've had a look at Device Manager and IDE ATA/ATAPI CONTROLLERS - then i
select Primary IDE channel and this is what i have....

Device 0

Device Type - Auto Detection
Transfer Mode - DMA If Available
Current Transfer Mode - Ultra DMA Mode 5

Device 1

Device Type - Auto Detection
Transfer Mode - DMA If Available
Current Transfer Mode - PIO Mode





- now looking at this....me thinks I need to change the bottom setting

to
Current Transfer Mode to Ultra DMA mode 5 too



- if i delete the primary IDE channel and re-boot would it pick it up?


Sorry if I appear clueless but ....I am (lol)







"SleeperMan" wrote in message
...
True. I never thought of that...
But, to DaveB: Does device manager says DMA if available and below

line
Ultra DMA x (1 or 2 i believe), or second line says PIO? Second line
actually states real state of IDE controller.

Dan G typed:

There's no need to mess with the registry. Go to device manager and
uninstall the IDE controller that the drive is on. Then reboot and

it
should be good.


"DaveB" wrote in message
...
Sleeperman, thanx for reply

Xp says system is running with DMA enabled, but when i check using
Nero it says DMA is turned off.

I've been to Device Manager but it keeps reporting that all is
running with DMA enabled , but the read/write speed is super slow,
only doing at best 1.1x and taking an hour or more to read.

Your solution looks like it might do the trick but it'll be Mon

nite
before i try it - I've never fiddled with the registry before so i
hope it all works out OK.




MAny thanks

Dave


"SleeperMan" wrote in message
...
DaveB typed:

Mydvd writer is reading dvds at single speed ..and it is really
frustrating....

Can some kind soul put me out f my misery and tell me how to turn
DMA back on (enable)

Thanx as always

Dave

If you run XP, i think this is what you wanted:

Getting back to DMA mode in Windows XP


CD-ROM and DVD-ROM drives can revert to using PIO mode, despite
being set to use "DMA if Available." Here's how to make Windows XP
redetect the DMA capabilities of the drives.
This behaviour occurs with the following conditions:
Windows XP is the operating system
A CD-ROM or DVD-ROM drive, which is known to support DMA mode now
works only in PIO mode.
The drive controller is set to use "DMA if available" but reports
to be only in PIO mode.
Following is the mechanism that has worked for me, please try it

at
your own risk, it involves hacking the registry:

Open RegEdit

Find the following KEY:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Contro l\
Class\{4D36E96A-E325-11CE-BFC1-08002BE10318}\000x

The last four digits will be 0000, 0001, 0002, 0003, and so on.
Under each key, delete all occurences of the following values:
MasterIdDataChecksum
SlaveIdDataChecksum
Reboot the computer. Windows will now redetect DMA settings.
Trala!









  #9  
Old June 15th 04, 02:34 AM
Theo
external usenet poster
 
Posts: n/a
Default

"Dan G" wrote in :

This a common issue with XP


im surprised they didnt fix it in the service pack.
  #10  
Old June 15th 04, 03:28 AM
Dan G
external usenet poster
 
Posts: n/a
Default

I think they consider it a "feature".


"Theo" wrote in message
...
"Dan G" wrote in :

This a common issue with XP


im surprised they didnt fix it in the service pack.



 




Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
wanted parts Intel MotherBoard SE440BX-2, i/o rear case shield, power connector on/off Steve C General 1 May 24th 04 08:29 PM
Where can I find a grounded electrical appliance in my room? Juha Kettunen General 12 August 13th 03 04:46 PM


All times are GMT +1. The time now is 09:03 PM.


Powered by vBulletin® Version 3.6.4
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.
Copyright 2004-2022 HardwareBanter.
The comments are property of their posters.