A computer components & hardware forum. HardwareBanter

If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

Go Back   Home » HardwareBanter forum » Video Cards » Ati Videocards
Site Map Home Register Authors List Search Today's Posts Mark Forums Read Web Partners

3Dmark05 & Radeon 9800 Pro: DirectX Problem



 
 
Thread Tools Display Modes
  #1  
Old October 1st 04, 07:46 AM
nSurfer Tom
external usenet poster
 
Posts: n/a
Default 3Dmark05 & Radeon 9800 Pro: DirectX Problem

I installed DirectX9.0b few months ago then had Omega Radeon driver
installed (2kXP OMEGA DRIVERS 2.5.67 8-22-04) several weeks ago.

Recently I downloaded 3Dmark05, and this little pop-up windows says:
Direct3DCreate failed.

Uninstalled that and installed Cataylst 4.9. Reinstalled 3dmark05. Same
thing. Tried to fix this by installing DirectX 9.0c (using dxwebsetup). No
go. (pulls hair) I uninstalled 3Dmark05. Now got to reinstall DirectX 9.0c
SDK then install 3dmark05 once again.

Still that darned "Direct3DCreate9 failed." window popup!!

This on a ASUS P4P800-VM
1gb dual ddr
Radeon 9800PRO 128mb
Maxtor 30gb & 120gb
LiteON DVD writer
running on WinXP (no service packs)





  #2  
Old October 1st 04, 07:50 AM
Andrew
external usenet poster
 
Posts: n/a
Default

On Fri, 01 Oct 2004 06:46:11 GMT, "nSurfer Tom"
wrote:

Recently I downloaded 3Dmark05, and this little pop-up windows says:
Direct3DCreate failed.


Do your games work fine? If it is just 3DMark05 that doesn't work, I
wouldn't worry too much, it will only depress you seeing your 9800Pro
reduced to single digit framerates.
--
Andrew, contact via interpleb.blogspot.com
Help make Usenet a better place: English is read downwards,
please don't top post. Trim replies to quote only relevant text.
Check groups.google.com before asking an obvious question.
  #3  
Old October 1st 04, 11:46 AM
Wayne Youngman
external usenet poster
 
Posts: n/a
Default


"nSurfer Tom"wrote
Still that darned "Direct3DCreate9 failed." window popup!!



Works ok here, I had the same thing as you but after i D/L the *full* DX9c
package and installed it works (I also have sp/2).
--
Wayne ][


  #4  
Old October 1st 04, 01:42 PM
nSurfer Tom
external usenet poster
 
Posts: n/a
Default



Do your games work fine? If it is just 3DMark05 that doesn't work, I
wouldn't worry too much, it will only depress you seeing your 9800Pro
reduced to single digit framerates.


Yes, other games works. 3Dmark03 pops up like it did before with no
problems.
Just this sick 3Dmark05's silly tiny window pop-up. I don't care about
scores,
just all I wanted was to see how pretty it is after seeing those marvelous
screenshots.



  #5  
Old October 1st 04, 06:17 PM
Shawk
external usenet poster
 
Posts: n/a
Default


"nSurfer Tom" wrote in message
news:[email protected]_s03...


Do your games work fine? If it is just 3DMark05 that doesn't work, I
wouldn't worry too much, it will only depress you seeing your 9800Pro
reduced to single digit framerates.


Yes, other games works. 3Dmark03 pops up like it did before with no
problems.
Just this sick 3Dmark05's silly tiny window pop-up. I don't care about
scores,
just all I wanted was to see how pretty it is after seeing those marvelous
screenshots.




On my 9800Pro it still looks like screenshots :-(


  #6  
Old October 2nd 04, 05:33 AM
Wayne Youngman
external usenet poster
 
Posts: n/a
Default


"Shawk" wrote
On my 9800Pro it still looks like screenshots :-(



Lol!
Don't be such a drama queen :P it looks ok on my system and I have a humble
Sapphire 9800 (440/390 though!). It's certainly not smooth though, but good
enough to get a feel for things!. In the return to proxycon when that dude
with the rail gun lets off! looks like a proper film!. . . I can't believe
how good the 3D is these days.

There is allot of guys running whizz-bang A64/6800Ultras/X800XT who are
still getting choppy results! and they are not happy!

Call of Duty plays like silk though, and even Doom3 plays well on my 9800. .
..

Next stop, a 512Mb video card for me, maybe 6 months time?
--
Wayne ][


  #7  
Old October 2nd 04, 03:37 PM
Shawk
external usenet poster
 
Posts: n/a
Default


"Wayne Youngman" wrote in message
...

"Shawk" wrote
On my 9800Pro it still looks like screenshots :-(



Lol!
Don't be such a drama queen :P it looks ok on my system and I have a
humble Sapphire 9800 (440/390 though!). It's certainly not smooth though,
but good enough to get a feel for things!. In the return to proxycon when
that dude with the rail gun lets off! looks like a proper film!. . . I
can't believe how good the 3D is these days.

There is allot of guys running whizz-bang A64/6800Ultras/X800XT who are
still getting choppy results! and they are not happy!

Call of Duty plays like silk though, and even Doom3 plays well on my 9800.
. .

Next stop, a 512Mb video card for me, maybe 6 months time?
--
Wayne ][


Yeah, I want that gun!! Dont care what the game is but someone PLEASE do a
mod so I can use it. :-)


  #8  
Old October 3rd 04, 01:54 PM
nSurfer Tom
external usenet poster
 
Posts: n/a
Default

I found the solution- I used DirectX Eradicator 1.09 Beta 2 to uninstall
DX9, it asked for
original WinXP CD to replace it with DX8.1, then rebooted fine. Then I
installed DX9c.
Now I can run 3Dmark05! Wow! Beautiful to view but choked my P4 3ghz &
Radeon 9800Pro
to a near slideshow in some places! If you wanna know the score, it's
2,342.

Get he
http://files1.majorgeeks.com/files/7...7705c/drivers/
dxe109b2.zip


 




Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Saphire Radeon 9800 Pro Atlantis... ???? Opticreep Ati Videocards 2 August 31st 04 08:29 AM
Radeon 9800 Pro - Antialiasing Not Working In DirectX Games AWU Ati Videocards 0 July 28th 04 06:58 AM
Question about OS support with Radeon 9800 or X800 Pro Kevin Middleton Ati Videocards 10 May 24th 04 09:49 PM
Tyan Thunder K8W S2885 and ATI Radeon 9800 Pro problems. Kris von Mach Ati Videocards 0 January 23rd 04 11:28 PM
Weird DirectX 7 / AGP Fast Writes Problem Wayne Bradney Ati Videocards 3 August 15th 03 11:55 PM


All times are GMT +1. The time now is 11:14 AM.


Powered by vBulletin® Version 3.6.4
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.
Copyright 2004-2022 HardwareBanter.
The comments are property of their posters.