PDA

View Full Version : linux with 3 nvidia pci-e cards


dup
April 26th 07, 02:48 PM
I have a asus p5n32-e sli mb with 3 pci-e slots.
When I put 3 nvidia(7600) dual heads in it,nvidia-settings only detects two
gpu's.In the log I get an error that gpu 2 (got gpu 0 and gpu 1) could not
be initialized.
Tried different linux distro's,different bios settings but no go.
Lspci gives me the 3 video cards(on 1.0.0 and 5.0.0 and 1.0.0(also as
0a.0.0).
Tried the latest nvidia driver and ubuntu drivers.No go.

thanks

Ed Medlin
April 26th 07, 04:04 PM
"dup" > wrote in message
...
>I have a asus p5n32-e sli mb with 3 pci-e slots.
> When I put 3 nvidia(7600) dual heads in it,nvidia-settings only
> detects two
> gpu's.In the log I get an error that gpu 2 (got gpu 0 and gpu 1) could
> not
> be initialized.
> Tried different linux distro's,different bios settings but no go.
> Lspci gives me the 3 video cards(on 1.0.0 and 5.0.0 and 1.0.0(also as
> 0a.0.0).
> Tried the latest nvidia driver and ubuntu drivers.No go.
>
> thanks

2 of those slots are PCIe X16 (most all video cards) and the other is
probably an X8 PCIe slot for PCIe sound cards and other peripherals.


Ed

dup
April 26th 07, 04:47 PM
Ed Medlin wrote:

>
> "dup" > wrote in message
> ...
>>I have a asus p5n32-e sli mb with 3 pci-e slots.
>> When I put 3 nvidia(7600) dual heads in it,nvidia-settings only
>> detects two
>> gpu's.In the log I get an error that gpu 2 (got gpu 0 and gpu 1) could
>> not
>> be initialized.
>> Tried different linux distro's,different bios settings but no go.
>> Lspci gives me the 3 video cards(on 1.0.0 and 5.0.0 and 1.0.0(also as
>> 0a.0.0).
>> Tried the latest nvidia driver and ubuntu drivers.No go.
>>
>> thanks
>
> 2 of those slots are PCIe X16 (most all video cards) and the other is
> probably an X8 PCIe slot for PCIe sound cards and other peripherals.
>
>
> Ed
Thanks,
But they are indeed slots for video-cards.I did the tric once with an early
ubuntu feisty,but now it's not possible anymore.
Nvidia-settings showing me only a 16x gpu0 and a 8x gpu1

dup
April 26th 07, 08:41 PM
dup wrote:

> I have a asus p5n32-e sli mb with 3 pci-e slots.
> When I put 3 nvidia(7600) dual heads in it,nvidia-settings only detects
> two gpu's.In the log I get an error that gpu 2 (got gpu 0 and gpu 1) could
> not be initialized.
> Tried different linux distro's,different bios settings but no go.
> Lspci gives me the 3 video cards(on 1.0.0 and 5.0.0 and 1.0.0(also as
> 0a.0.0).
> Tried the latest nvidia driver and ubuntu drivers.No go.
>
> thanks
solved:
it was a nvram error

add at boot menu:
vmalloc=256MB pci=nommconf